本文隶属于分类

编程语言

广告推荐

技术交流学习或者有任何问题欢迎加群

编程技术交流群 : 154514123 爱上编程      Java技术交流群 : 6128790  Java

标签:plot   global   install   sim   can   版本   结果   codec   error:   

事情是这样的,好不容易找到了【含代码而不止代码】的教程:


  (知乎回答)


  但是我用的是windows,还是win7,怎么办?有代码就好说,代码里不是有“from keras……”嘛,二话不说,pip!(感谢官方安装包自带的pip)

pip install -U keras


  然后华华丽丽的出错了,最后一行是这样的:

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb3 in position 3: invalid start byte


  我用的Powershell,满屏的红色报错。但是查了查发现可以改pip程序,那个教程在哪里忘了,讲的是__init__文件中有个utf-8要改成gbk,但是那个教程是针对anaconda的,我可是堂堂正正从官网下的python……巧的是报错代码里也有个__init__文件(连行号都有!),那就改那里好了……(下面是红字的前几行)

Exception:
Traceback (most recent call last):
    File "c:\users\administrator\appdata\local\programs\python\python36\lib\site-packages\pip\compat\__init__ .py, line 73, in console_to_str
        return s.decode(sys.__stdout__.encoding)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb3 in position 3: invalid start byte


  简单修改——

原来的代码:

            return s.decode(sys.__stdout__.encoding)

修改后的代码:

            ###return s.decode(sys.__stdout__.encoding)    (原版当成注释,天知道以后会不会改回来)
            return s.decode('gbk')


  重新执行命令:

pip install -U keras


  成功!哈哈哈我真是个天才……


  第二个import的是叫……“matplotlib”……

pip install matplotlib


  忘记加-U了,不过似乎没什么可update,也罢。一次成功。(之前的改动不影响别的安装的啊?)


  试着运行了一下代码,结果第一行就报错,在 keras 的导入里,竟然还有包括了个导入 import TensorFlow …… (果然是TensorFlow的教程,我说怎么还没装它)

pip install tensorflow


  我已经不想再现当时的情况了。大致的回应很简单:pip没有找到TensorFlow 。于是我上网查,说可以把命令里的tensorflow换成.whl文件的网址,换了几次都说没有,终于有一次说找到了,但是版本不匹配……


  这实在是匪夷所思的事,https://storage.googleapis.com/tensorflow/windows/cpu/tensorflow-1.2.1-cp36-cp36m-win_amd64.whl,毕竟cp36是python3.6,64是64位,windows文件夹说明是windows系统,既然这个文件存在,那我就该能用啊?之前看到说TensorFlow只支持py3.5以上  + 64位……慢着!


  我想起来了,我当年下python点的是官网最醒目的下载按钮,那是默认32位的!我用64位机装了32位python!赶紧去下64位的python,安装的时候连覆盖提示都没有。然后(很不情愿地)重启电脑——

pip list


  在此之前,我也用过这个命令,第三方库占了一条多屏幕。而现在,只剩下了pip和setuptools,我装的库都没了,恍如一场大梦。

  另外还给了警告,查了下便在C:\Users\Administrator下建了个pip文件夹,往里写了一个pip.ini :

[global]
index-url = http://mirrors.aliyun.com/pypi/simple/  
[install]
trusted-host=mirrors.aliyun.com 

[list]
format=columns


  前一部分是用阿里云镜像pip,另一部分是list命令给出默认值。于是再次——

pip install tensorflow


  文件找到了,但还是报错:

Unknown requires Python '>=2.6, <3' but the running Python is 3.6.4


  但这个错误很快查到了解决,使用如下命令:(pip命令和pip3命令是一回事,可以混用)

pip3 install futures==3.1.1


  再次 pip install tensorflow, 成功。


  真(他妈)感人。


  (然而作为AMD显卡用户,没有用GPU。我的另一台电脑是NVIDIA,32位win7 。这台的CPU是传说中不可打游戏的G4560,另一台反正比这个还差得多)


  (2018-2-1 于地球)

Windows 下 Python 3.6 下安装 TensorFlow (屡败屡战)

标签:plot   global   install   sim   can   版本   结果   codec   error:   

原文:http://blog.51cto.com/13535617/2067777

技术交流学习或者有任何问题欢迎加群

编程技术交流群 : 154514123 爱上编程      Java技术交流群 : 6128790  Java

广告推荐

讨论区