本文隶属于分类

Web开发

广告推荐

技术交流学习或者有任何问题欢迎加群

编程技术交流群 : 154514123 爱上编程      Java技术交流群 : 6128790  Java

标签:class   style   log   com   http   si   it   使用   代码   

IE浏览器兼容性后续

前言

      继续尝试解决IE浏览器兼容性问题,结局方案为更换jqueryangularjsIE的版本。

      1.首先尝试更换jquery版本为1.7.2

      jquery-1.9.1.js --> jquery-1.7.2.js -->  jquery2.1.4.js 无效

      2.尝试更换IE版本IE8

      IE11 --> IE8(本机系统不支持) --> IE10

      angular-1.3.0.14 -->angular-1.2.0

 技术分享

    相关代码如下:

<div class="container">

<div class="row">

    <div class="col-md-2">

        <div ui-view="sys_banner">

         导航栏加载中...

        </div>

    </div>

    <div class="col-md-10" style="padding-left50px">

        <div ui-view="rightContent">

         内容信息加载中...

        </div>

    </div>

</div>

</div>

      由此可见,兼容性问题导致的原因大致为angular版本不兼容导致的。相关视图没有加载上。

      搞了一上午,没有任何进展,放弃了。

1IE浏览器与360安全浏览器的区别

      IE浏览器是Windows操作系统自带的浏览器,360安全浏览器的是IE的加强版。

      360安全浏览器为双内核,除了IE内核,还有谷歌内核,不同内核效率不一样,非IE内核的更快更安全。

      在360浏览器地址栏右侧,点击可以切换模式。

      极速模式为谷歌内核,兼容模式为IE内核。

      对于某些页面,在IE中显示正常,在360极速模式下显示不正常的页面,点击切换到兼容模式即可显示。

      切换到兼容模式化,对切换的这个网站设置在本机上是记录下来的,也就是在兼容模式关闭后,下次打开这个网站,还是保留兼容模式。

2jQuery 2.0版本主要变化 

      不再支持IE 6/7/8,如果在IE9/10版本中使用“兼容性视图”模式也将会受到影响。

      更加轻量,2.0版本文件与1.9.1相比小了12%

      模块化,你可以自定义构建一个更小、更轻量的版本。

     兼容jQuery 1.9版本的API

参考文献

1.http://www.daqianduan.com/3696.html

2.http://www.jb51.net/article/68162.htm

美文美图

 技术分享

AngularJS进阶(三十七)IE浏览器兼容性后续

标签:class   style   log   com   http   si   it   使用   代码   

原文:http://blog.csdn.net/sunhuaqiang1/article/details/50804624

技术交流学习或者有任何问题欢迎加群

编程技术交流群 : 154514123 爱上编程      Java技术交流群 : 6128790  Java

广告推荐

讨论区